dduck's playground for blank html/css like back in the 90s
it is for privat use and the

do not F.A.Q. a duck

Powershell firewall rule windows 11

windows 11 does not answer a pingsituation

-

windows 11 standard firewall rule

-

solution


Set-NetFirewallRule -name FPS-ICMP4-ERQ-In-NoScope -Enabled True -RemoteAddress 192.168.0.66
Get-NetFirewallRule -name FPS-ICMP4-ERQ-In-NoScope | select name, enabled

netsh advfirewall firewall set rule profile=Domain name="Datei- und Druckerfreigabe (Echoanforderung - ICMPv4 eingehend)" new enable=yes remoteip=192.168.0.66

source


https://www.windowspro.de/wolfgang-sommergut/ping-windows-10-erlauben-gui-powershell-netsh-gpo
https://www.windowspro.de/tipp/ping-mittels-gpo-erlauben-windows-7-8x-server-2012-r2

libreNMS php composer error

situation

after disconnect from isci-hdd to his runnig server. the librenms server show php composer error.

analysis

hours later in the web ... you can find different or similar solutions what all they dont tell you (that i found) , is do you have to give the composer command as librenms user!

solution

connect to th librenms server per ssh
change to librenms-user

librenms@linbrenms: su librenms
librenms@linbrenms: composer global update
librenms@linbrenms: composer dump-autoload

source

-

Windows Print To PDF

situation

no possibly to change resolution / size of output

analysis

-

solution

C:\Windows\System32\spool\V4Dirs\C37144D0-7732-4FAB-A2AE-03A294610669
69b8a4a.gpd pdc.xml

source


https://superuser.com/questions/1151957/how-to-reduce-file-size-produced-by-microsoft-print-to-pdf#1533699
https://superuser.com/questions/1151957/how-to-reduce-file-size-produced-by-microsoft-print-to-pdf
https://franklinheath.co.uk/2015/08/29/custom-page-sizes-for-microsoft-print-to-pdf/
https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/microsoft-print-to-pdf-custom-paper-sizes-possible/90ed3d48-1ece-4ca5-8d3b-ff0af24a7b37
https://answers.microsoft.com/en-us/windows/forum/all/how-to-reduce-file-size-when-print-to-pdf/6dd3505d-9b2f-44c3-9902-af684dcdd5ac

Windows Office Key License

situation

read and set license key for office 2019

analysis

solution

open the cmd- or ps-shell as admin
call the command below
for office 32bit

>>request of installed eky<<
c:\>cscript C:\Program Files (x86)\Microsoft Office\Office16\OSPP.VBS /dstatus

>>delete the installed key<<
c:\>cscript C:\Program Files (x86)\Microsoft Office\Office16\OSPP.VBS /unpkey:KHGM9

>>set the new key<<
c:\>cscript C:\Program Files (x86)\Microsoft Office\Office16\OSPP.VBS /inpkey:

for office 64bit version

office64 open cmd as admin

>>request the installed key<<
cscript "C:\Program Files\Microsoft Office\Office16\OSPP.VBS /dstatus

>>delete the installed key<<
cscript "C:\Program Files\Microsoft Office\Office16\OSPP.VBS /unpkey:KHGM9

>>set the new ey<<
cscript "C:\Program Files\Microsoft Office\Office16\OSPP.VBS /inpkey:

>>hint<<
change the directory using

[host]: PS C:\> cd 'C:\Program Files\Microsoft Office\Office16\'
[host]: PS C:\Program Files\Microsoft Office\Office16> dir

Verzeichnis: C:\Program Files\Microsoft Office\Office16

Mode LastWriteTime Length Name
---- ------------- ------ ---- -a---- 01.02.2002 18:02 174528 OSPP.HTM
-a---- 01.02.2002 18:02 105198 OSPP.VBS
-a---- 01.02.2002 18:02 198992 OSPPREARM.EXE
-a---- 01.02.2002 18:02 36336 SLERROR.XML
-a---- 01.02.2002 18:02 20350 vNextDiag.ps1

[host]: PS C:\Program Files\Microsoft Office\Office16>cscript .\ospp.vbs

source

-

Chrome without print menu

situation

Windows10 print menu dismatch the default print settings of windows

analysis

print menu dismatch the default print settings of window

solution

edit google chrome shortcuts and use follow commands
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --kiosk-printing --disable-print-preview

source

https://www.maketecheasier.com/enable-disable-google-chrome-print-preview/

delete and create partition on freeBSD

situation

In the process of installing freenas could not remove the partition of the system disk. it give an error "writing not permitted ont the disk /dev/dxx".

analysis

solution

Jump back in the freenas install console menu and select the "shell".

source


https://www.freebsd.org/cgi/man.cgi?query=geom
https://forums.freebsd.org/threads/gpart-cheatsheet-wiping-drives-partitioning-formating.45411/
https://www.unix.com/man-page/FreeBSD/8/GPART/
https://www.cyberciti.biz/faq/freebsd-hard-disk-information/

delete and create partition on MSWindows

situation

cleaning a windows hdd bevor reinstalling or usb stick

analysis

solution

Datenträger ### Status Größe Frei Dyn GPT
--------------- --- ------------- ------- ------- --- ---
Datenträger 0 Online 1863 GB 1024 KB *
Datenträger 1 Online 476 GB 1024 KB *

source


https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/windows-setup-installing-using-the-mbr-or-gpt-partition-style

Copy VMware and Downgrad

moving VMware machines from one host and downgrade

I had to move different VMachines to another host. 3 centos machines OTRS, Nextcloud, MariaDB 1 Debian Observer (Turnkey)

analysis

1. moving over net 2. downgrade from 7.0 to 6.5

solution


1. connect both VM-Ware hosts to the same iSCSi volume on freenas.
2. stop the machines
3. copy the whole directorys from one machine to the connect storage folder
4. connect per ssh to the VM-Ware host and edit the "vi *.vmx" file. Searching "/HW.v"

.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "17"
vmci0.present = "TRUE"
floppy0.present = "FALSE"
numvcpus = "2"
memSize = "8192"

change the "17" to "13"

5. Go to "Create/Register" on the VMware webUI.
"Register an existing virtual machine"
"Select one ore more virtual machines, a datastore or a directory"

source


https://tylermade.net/2018/04/25/how-to-downgrade-virtual-machine-hardware-version-vmware/
https://www.altaro.com/vmware/4-ways-to-downgrade-the-vm-hardware-version/

https://kb.vmware.com/s/article/1003746

ZFS Command Reference

situation

text

analysis

text

solution

source


https://itsjustbytes.com/2020/05/10/zfs-command-line-reference-cheat-sheet

Firefox Cert Store

situation

Firefox does not accept cert from own pki

analysis

Firefox does not accept cert from own pki

solution

2 methods that firefox let windows cert store read 1. call configuration with "about:config" create new key "security.enterprise_roots.enabled" value "true" 2. GPO Admin=>Mozilla>Firefox=>Certificate "use windows cert store" "activate"

source


https://www.windowspro.de/tipp/windows-zertifikatspeicher-firefox-nutzen

silencing a DELL 730 server

situation

the DELL 730 server fan are incredible loud. sometimes it can be usefull to switch the fan down manually. if the ipmi loose

analysis

solution

install on centOS
step 1. install on a centos machine "dnf install ipmitool". on the net you can find that you have to install "openipmi (lib)". i can't confirm that.
step 2. in the DELL IDRAC WebUI do you have to go IDRAC-config => Network => Network => IPMI-Config switch on "IPMI-over-LAN activate".
step 3. make sure do you can connect via ssh to the IDRAC => Network => Services => SSH switch on "activate"
step 4. make sure do you have an account on the IDRAC-config => User-Authentication => Local-Users - In my case I created a special user "ipmi"
step 5. in my case i did build an centos VM and installed IPMI-Tools here. at my knowledge ipmitools only exist for red hat/centos and windows/PS.

on debian works same way.
step 1. apt-get install ipmitool

explaincommand
#Enable automatic fan controlraw 0x30 0x30 0x01 0x01
#Disable automatic fan control raw 0x30 0x30 0x01 0x00
#command to turn defaultraw 0x30 0xce 0x00 0x16 0x05 0x00 0x00 0x00 0x05 0x00 0x00 0x00 0x00
#command to check the statusraw 0x30 0xce 0x01 0x16 0x05 0x00 0x00 0x00
#0%raw 0x30 0x30 0x02 0xff 0x00
#20%raw 0x30 0x30 0x02 0xff 0x14
#25%raw 0x30 0x30 0x02 0xff 0x19
#30%raw 0x30 0x30 0x02 0xff 0x1e
#50%raw 0x30 0x30 0x02 0xff 0x32
#60%raw 0x30 0x30 0x02 0xff 0x3C
#100%raw 0x30 0x30 0x02 0xff 0x64



user@server:/# ipmitool -I lanplus -H SERVERS_IP_HERE -U IDRAC_USERNAME -P 'IDRAC_PASSWORD_HERE' raw 0x30 0x30 0x01 0x00
user@server:/# ipmitool -I lanplus -H SERVERS_IP_HERE -U IDRAC_USERNAME -P 'IDRAC_PASSWORD_HERE' raw 0x30 0x30 0x02 0xff 0x14

source

https://back2basics.io/2020/05/reduce-the-fan-noise-of-the-dell-r720xd-plus-other-12th-gen-servers-with-ipmi/
https://www.reddit.com/r/homelab/comments/d7u7jt/dell_r720_fan_noise_control_via_ipmi/
https://www.thomas-krenn.com/de/wiki/Ipmitool_zur_Sensorabfrage_von_Servern_nutzen9
https://gist.github.com/mdpuma/8972079b7da52afef15cc039039ff818
https://www.reddit.com/r/homelab/comments/7xqb11/dell_fan_noise_control_silence_your_poweredge/
https://www.debiantutorials.com/installing-and-using-the-ipmi-tool/

install desktop XFC auf Centos 7

situation

Install desktop XFC auf Centos 7. Works also on Centos 8.

analysis

solution

Install Xfce Desktop Environment on here (You will need to add the EPEL Repository as like above in "Cinnamon" installation before). # yum -y install epel-release # sed -i -e "s/\]$/\]\npriority=5/g" /etc/yum.repos.d/epel.repo # set [priority=5] # sed -i -e "s/enabled=1/enabled=0/g" /etc/yum.repos.d/epel.repo # for another way, change to [enabled=0] and use it only when needed # yum --enablerepo=epel install [Package] # if [enable # yum -y groupinstall X11 # yum --enablerepo=epel -y groups install "Xfce" Input a command like below after finishing installation: # echo "exec /usr/bin/xfce4-session" >> ~/.xinitrc # startx Xfce Desktop Environment starts.

source


https://unix.stackexchange.com/questions/181503/how-to-install-desktop-environments-on-centos-7

proxmox cluster deinstallation

situation

created cluster but only on a stand allone installation have to remove

analysis

solution

source


https://pve.proxmox.com/wiki/Proxmox_Cluster_File_System_(pmxcfs)
https://pve.proxmox.com/wiki/Cluster_Manager#pvecm_separate_node_without_reinstall https://support.mozilla.org/de/questions/1300809

switch on snmpd on vmware

situation


sometimes you cant activate snmpd on vmware over the webui ... the easy way is the ssh connection to the vmware machine and ...

analysis

solution


esxcli system snmp set --communities public
esxcli system snmp set --enable true

source

situation

got 5-year old hardware and have to change dell chassisname and identification id

analysis


/admin1-> racadm
racadm>>getsysinfo

racadm getsysinfo

RAC Information:
RAC Date/Time = Wed Sep 30 11:40:19 2020

Firmware Version = 2.65.65.65
Firmware Build = 15
Last Firmware Update = 09/25/2020 16:53:13
Hardware Version = 0.01
MAC Address = xx:xx:xx:xx:xx

Common settings:
Register DNS RAC Name = 1
DNS RAC Name = iDRAC4
Current DNS Domain = xxxxxxxxxxxxx
Domain Name from DHCP = Disabled

IPv4 settings:
Enabled = 1
Current IP Address = xx.xx.xx.xx
Current IP Gateway = xx.xx.xx.xx
Current IP Netmask = 255.255.252.0
DHCP Enabled = 0
Current DNS Server 1 = xx.xx.xx.xx
Current DNS Server 2 = xx.xx.xx.xx
DNS Servers from DHCP = Disabled

IPv6 settings:
Enabled = 0
Current IP Address 1 = ::
Current IP Gateway = ::
Autoconfig = 0
Link Local IP Address = ::
Current IP Address 2 = ::
Current IP Address 3 = ::
Current IP Address 4 = ::
Current IP Address 5 = ::
Current IP Address 6 = ::
Current IP Address 7 = ::
Current IP Address 8 = ::
Current IP Address 9 = ::
Current IP Address 10 = ::
Current IP Address 11 = ::
Current IP Address 12 = ::
Current IP Address 13 = ::
Current IP Address 14 = ::
Current IP Address 15 = ::
DNS Servers from DHCPv6 = Disabled
Current DNS Server 1 = ::
Current DNS Server 2 = ::

System Information:
System Model = PowerEdge M520
System Revision = I
System BIOS Version = 2.9.0
Service Tag = xxxxxxx
Express Svc Code = xxxxxxxxxxxx
Host Name = VMware04
OS Name = VMware ESXi
OS Version = 6.5.0 U3 build-16576891
Power Status = ON
Fresh Air Capable = Yes

Watchdog Information:
Recovery Action = None
Present countdown value = 15 seconds
Initial countdown value = 15 seconds

System Thermal Information:
EstimatedSystemAirflow = NA
EstimatedExhaustTemperature = NA

Embedded NIC MAC Addresses:
NIC.Embedded.1-1-1 Ethernet = xx:xx:xx:xx:xx
NIC.Embedded.2-1-1 Ethernet = xx:xx:xx:xx:xx

racadm>>config -g

cfgActiveDirectory
cfgEmailAlert
cfgIPv6LanNetworking
cfgIPv6StaticLanNetworking
cfgIPv6URL
cfgIpmiLan
cfgIpmiPef
cfgIpmiSol
cfglannetworking
cfgLDAP
cfgLdapRoleGroup
cfgLogging
cfgOobSnmp
cfgRacSecurity
cfgractuning
cfgRacVirtual
cfgRemoteHosts
cfgserial
cfgserverInfo
cfgServerPower
cfgSessionManagement
cfgSmartCard
cfgStandardSchema
cfgStaticLanNetworking
cfguseradmin
cfgUserDomain
cfgVFlashPartition
cfgVFlashSD
ifcRacManagedNodeOs

racadm>>config -g ifcRacManagedNodeOs -o

ifcRacMnOsHostname
ifcRacMnOsOsName
ifcRacMnOsOsVersion

racadm>>config -g ifcRacManagedNodeOs -o ifcracmnoshostname VMware09

racadm config -g ifcRacManagedNodeOs -o ifcracmnoshostname VMware09
Object value modified successfully

RAC1169: The RACADM "config" command will be deprecated in a future version of iDRAC firmware. Run the RACADM "racadm set" command to configure the iDRAC configuration parameters. For more information on the set command, run the RACADM command "racadm help set".

racadm>>exit

source

https://www.dell.com/downloads/global/power/ps2q06-20060105-Zhang-OE.pdf
https://www.dell.com/support/article/de-de/sln266160/dell-poweredge-how-do-i-change-the-system-host-name-on-the-idrac
http://lifeofageekadmin.com/using-dell-racadm-on-redhat-centos/
https://cs.uwaterloo.ca/~brecht/servers/docs/PowerEdge-2600/en/Racadm/racadmc1.htm
https://www.aftershox.com/2013/07/11/how-to-configure-a-dell-idrac-card-using-the-racadm-command-line-tool/

Mozilla Thunderbird does not connect correctly to mail server after update to 78.1.1

situation

Since upgrading to Thunderbird 78.1.1 (32-bit) I'm not able to receive emails from my pop server and when i try to send an email I get the following error message.
"Sending of the message failed. Peer reports incompatible or unsupported protocol version. The configuration related to mail.******.com must be corrected."

analysis

the mail server is working intern with an old version. so i had to say TB it have to accept this kind of connection.

solution

If you have been effected by Thunderbird 78 changing the minimum tls security level to TLSv1.2 and the server you get emails downloaded from is not using the most up to date protocol then you not be able to get access to server using original server settings. Suggest you test this by trying a reset of the minimum version which by default is now set to 3. To test this you can do one of the following: Using original server settings. Menu app icon > Options. Scroll all the way to the bottom and click on 'Config Editor' button. Skip past the warning. In search type: tls.version Look for this line: security.tls.version.min Double click on that line to open edit window set the value to 1 click on OK Restart Thunderbird. If this gets you access, then you have a choice. Either leave that setting in place OR Revert the setting for 'security.tls.version.min' back to 3 and try changing the server settings to use: Port : 110 Connection Security: try 'STARTTLS', if it still fails then try 'None'

source

https://support.mozilla.org/de/questions/1300809

linux shell login message

situation

login message for non-linux colleagues to send some hints and infos create a file "whatevername.sh" in "/etc/profile.d/" in my case i create "loginmessage.sh" and write something like this...
echo ""
echo "########################################"
echo "#for GUI connect to this machine with Remotedesktop#"
echo "########################################"
echo " mariaDB Datenbankserver "
echo ""
loginmessage.sh (END)
Web console: https://xxx-mariadb.xxx-net.local:9090/ or https://xx.xx.xx.xx:9090/
Last login: Tue Sep 8 07:22:51 2020 from xx.xx.xx.xx

########################################
#for GUI connect to this machine with Remotedesktop#"
########################################

mariaDB Datenbankserver

smb-protocol samba
1325 10.423559 10.9.254.99 10.9.254.77 TCP 54 50178 ? 445 [RST, ACK] Seq=1095 Ack=817 Win=0 Len=0

situation

network with windows10 clients loosing their connection to the samba-shares on a linux box. 10.9.254.77 = smb-share server 10.9.254.99 = win10 client

analysis

the tcpdump did show the following traffic between win10 client and the samba-server.

1218 9.406740 10.9.254.77 10.9.254.99 NBNS 104 Name query response NB 10.9.254.77
1219 9.406740 10.9.254.77 10.9.254.99 NBNS 104 Name query response NB 10.9.254.77
1303 10.407656 10.9.254.99 10.9.254.77 TCP 66 50178 ? 445 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 WS=256 SACK_PERM=1
1304 10.408045 10.9.254.77 10.9.254.99 TCP 66 445 ? 50178 [SYN, ACK] Seq=0 Ack=1 Win=64240 Len=0 MSS=1460 SACK_PERM=1 WS=128
1305 10.408154 10.9.254.99 10.9.254.77 TCP 54 50178 ? 445 [ACK] Seq=1 Ack=1 Win=2102272 Len=0
1306 10.408287 10.9.254.99 10.9.254.77 SMB 213 Negotiate Protocol Request
1307 10.408674 10.9.254.77 10.9.254.99 TCP 60 445 ? 50178 [ACK] Seq=1 Ack=160 Win=64128 Len=0
1308 10.413635 10.9.254.77 10.9.254.99 SMB2 260 Negotiate Protocol Response
1309 10.413794 10.9.254.99 10.9.254.77 SMB2 280 Negotiate Protocol Request
1310 10.414332 10.9.254.77 10.9.254.99 SMB2 326 Negotiate Protocol Response
1319 10.419983 10.9.254.99 10.9.254.77 SMB2 220 Session Setup Request, NTLMSSP_NEGOTIATE
1321 10.420492 10.9.254.77 10.9.254.99 SMB2 307 Session Setup Response, Error: STATUS_MORE_PROCESSING_REQUIRED, NTLMSSP_CHALLENGE
1323 10.421383 10.9.254.99 10.9.254.77 SMB2 597 Session Setup Request, NTLMSSP_AUTH, User: LOCALNET\netuser
1324 10.422765 10.9.254.77 10.9.254.99 SMB2 139 Session Setup Response
1325 10.423559 10.9.254.99 10.9.254.77 TCP 54 50178 ? 445 [RST, ACK] Seq=1095 Ack=817 Win=0 Len=0

see the handshake failed by the client. the reason was unclear. all solution in the net lead back the reason to a smb1/smb2 problem.
they recommend "allowinsecureguestauth: 1" as a parameter-key in the registry at the lanmanworkstation tree.

solution

the dc give a win7 gpo to the workstations that the "insecureguestauth" is not (more) allowed/unconfigured "AllowInsecureguestauth:dword 0" . this should be ignored by the workstation by default because this insecureguestauth is not more allowed by win10/smb2. but sometimes a workstation stumbled over this gpo/rule and write this parameter in their own registry. what let the smb2 protocol stumble. the solution in this case, was only to delete the complete key from registry and take the gpo from the dc away.

powershell: get-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\
remove-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\ -Name AllowInsecureguestauth

source

smb1-smb2 problem https://winxperts4all.at/index.php/betriebssysteme/windows-10/1808-unsichere-gastanmeldungen-aktivieren-in-windows-10
https://answers.microsoft.com/de-de/windows/forum/all/windows10-blockiert-netzwerkfreigabe-f%C3%BCr-nas/99cd9126-dade-4a08-bcc0-3bd1a24cd01e
https://de.minitool.com/datenwiederherstellung/zugriff-verweigert.html
https://ask.wireshark.org/question/15935/what-would-cause-a-rstack-from-client-to-smb-server/
https://www.johnpfernandes.com/2018/12/17/tcp-flags-what-they-mean-and-how-they-help/
https://robertheaton.com/2020/04/27/how-does-a-tcp-reset-attack-work/

Centos 8 munin-nodes need Power-Tools

https://blog.redbranch.net/2020/06/06/centos-8-munin-node-needs-powertools/

Depsolve Error occured: Problem: package munin-node-2.0.54-2.el8.noarch requires perl(Net::SNMP), but none of the providers can be installed\n - conflicting requests - nothing provides perl(Digest::SHA1) >= 1.02 needed by perl-Net-SNMP-6.0.1-25.el8.1.noarch

Solution

sed -i '/enabled=0/enabled=1/' /etc/yum.repos.d/CentOS-PowerTools.repo

munin snmp

situation

no chance to change something or rebuild, all nodes managed by cisco/meraki/veeam. only a little pool of linux boxes.

to monitor this little pool, i installed munin but stumpled over problems with snmp and the nature with the company network. there is no existing dns except the one for winAD.
1. editing /etc/hosts IP.ADD.RE.SS1 printer1 IP.ADD.RE.SS2 server2

2. /etc/munin/plugins
munin-node-configure -snmp ip.add.re.ss -shell

ln -s '/usr/share/munin/plugins/snmp__if_' '/etc/munin/plugins/snmp_99.9.99.66_if_1'
ln -s '/usr/share/munin/plugins/snmp__if_err_' '/etc/munin/plugins/snmp_99.9.99.66_if_err_1'
ln -s '/usr/share/munin/plugins/snmp__if_multi' '/etc/munin/plugins/snmp_99.9.99.66_if_multi'
ln -s '/usr/share/munin/plugins/snmp__netstat' '/etc/munin/plugins/snmp_99.9.99.66_netstat'
ln -s '/usr/share/munin/plugins/snmp__print_supplies' '/etc/munin/plugins/snmp_99.9.99.66_print_supplies'
ln -s '/usr/share/munin/plugins/snmp__uptime' '/etc/munin/plugins/snmp_99.9.99.66_uptime'

3./ munin-node-configure -snmp ip.add.re.ss -shell | bash

4. /etc/plugin-conf.d
every file in this folder is part of the plugin configuration no name confess.for printers i build file print.
vi print
name of the plugin link what munin-node-configuration did build.

[snmp_99.9.99.66*]
env.community public
env.host printer1
[snmp_99.9.99.67*]
env.community public
env.host printer2
2. /etc/munin.conf
[printer]
[printer;printer1]
address 127.0.0.1
use_node_name no
[printer;printer2]
address 127.0.0.1
use_node_name no
systemctl restart munin-node.service


After upgrade, the swap got a new UUID

after upgrading from debian 9 to 10 got the start job running for dev disk. long searches on different sites did not give me really a solution but a way to go... lsblk shows the dev and a !new! blkid for the dev. with blkid the new uuid written in fstab. but it was not the final solution. then i stumbled about this tiny hit on a site..
"when the comp is encrypted with cryptsetup ... you have to change the uuid in a file called "crypttab" too."
changing here sda6_crypt UUID=abcd123-4567-8901-0101-abcdefg01010101- none luks,swap